Creality Cr10 smart pro extruder issues

CR10 smart pro
Creality (Cura)

my printer after 1 week of printing great, started printing under extruded. (prints would crumble trying to get them off the mat. I did some research and ran a flow test. I set the machine to extrude 50mm and it extruded only 11mm. went into the e-step setting and found the printer set to 103. I am not sure what it was when it was printing great. I did some calculations and set the e-step to 419.1. Prints started coming out good again. What should the factory setting be for the e-step and if it did change then why did it change. or is the value supposed to be 103 and there is an extruder issue that adjusting the e-step makes up for a failing part?
This worked for a larger 2 day print. the next time I tried to print the e-step reset back to 103. I reset it back to 419.1 but it was still slow. Adjusted to 434.1 and it was good. Tried to print immediately after this and extruder was under extruding again. Checked e-step and it was still 434.1 but now only extruding 5mm again at the 50mm setting. Machine is not reliable. Not sure if the board is bad or the extruder is bad.

I have taken apart the extruder and there is nothing jamming it. When the machine is off I can easily roll the black extruder gear with my finger when there is no filament in there. I can push the filament through when the nozzle is hot.

Any help I would be grateful for. Creality has so far been next to useless, I don’t think I can get them to send me any parts since I did not buy the printer directly through them. They wanted 899.00 and B&H photo has them on sale for 499.00