Ender 6 - BIQU H2 Install stuck at firmware step

  • 3D Printer Model: Ender 6
  • Slicer: none
  • Hardware Setup: Stock Ender 6 except installing BIQU H2 with Pi/Klipper
  • Problem description: I have followed the guide to the letter. I do the main board flash and my screen sits with the loading bar blank as the instructions say. I let it go for a minute or 2. Have gone as long as 5 minutes. I power off, pull the regular SD card, go to the screen, put the microSD card in the DWIN_SET folder unzipped in the video microSD card slot, I power it up and the screen shows the same exact Creality loading screen as before minus the white loading bar. I leave is sit and it does not change. I never get any updating text.
  • What I tried: I have formatted both SD cards to the Fat32 with 4096 allocation multiple times. I have copied the DWIN_SET folder to the card after each format. I have created the Klipper.bin file 6 times, each time renaming it for the flash process. Each time i create the klipper file, I follow the steps of deleting the klipper directory on the pi unit and remake it with the same settings.

The only setting that is not explained fully on the instructions is the Screen Serial Port (USART3). in the make menuconfig area, mine has 2 options for USART3> USART3 (on PB11/PB10) or USART3 (on PD9/PD8) I have tried both.

I am very frustrated at this point and don’t know what to do. I’m about ready to throw this thing in the trash. I have had the printer for over a year and I was getting OK prints out of it with it stock, so I figured I could upgrade and get even better prints.