Ender 6, Klipper, Fluiddpi Help

  • 3D Printer Model: Ender 6
  • Slicer: Cura
  • Hardware Setup: Direct drive biqh2
  • Problem description:
    I have been using fluidd and klipper for some time now and after relocating i cant get it to talk to the printer anymore.

It comes up with the below in the fluid window and wont boot past the klipper screen on the printer.

Option ‘serial’ in section ‘mcu’ must be specified

Once the underlying issue is corrected, use the “RESTART”
command to reload the config and restart the host software.
Printer is halted

  • What I tried:
    I have tried reflashing the mainboard from the pi klipper.bin but no joy.


Did you rename the klipper.bin to something else before you reflashed it?

Another test:

When you open a serial terminal session ( at 115200 baud) with putty and you type the command “G28” (without the quotes), does the printer home?