Filament Change on Ender 3 S1 Pro

Ender 3 S1 Pro

  • Slicer: Creality, Cura, Prusa
  • Hardware Setup:?
  • Problem description: All of the slicers use M600 for a filament change but the stock Ender 3 S1 Pro does not recognize it. Even the Creality slicer has it. When I enable it at a particular height, the slicer puts it in. When I print, it does not stop but just keeps on printing.
  • What I tried: Searched the internet and the only thing I can find besides changing the firmware is to sit and wait and then hit pause, change the filament, and the resume.
    Besides being a PITA, the problem with that is that the LCD display does not show the Z value and therefore it’s a hit or miss.
    I’ve contacted Creality and the chat person said that M600 works. I informed him that it’s a known issue and that it doesn’t work. I then sent an email to tech support last week but haven’t heard back from them.
    There should be a gcode for a filament change.

Anyone interest I found the solution.

I love HATCHBOX PLA 3D Printer Filament and this is great because it does not require any heated print plate.

Thank you for your solution.