Need help flashing firmware to new motherboard Ender 3 S1 Pro

  • Creality Ender 3 S1 Pro:
  • Cura:
  • Hardware Setup:
  • **Printed with this fine for over a month. Heated bed stopped heating in the middle of a print. Diagnosed to bad connection on motherboard. Creality sent new mother board, which I installed, but couldn’t get it to accept firmware. **:
  • Formatted the card each time. Downloaded latest firmware. Also have Sonic Pad, which has latest updates, and have exported the firmware for that which worked perfect before, but nothing happens when I tried to flash the firmware. Sonic pad wasn’t able to connect. Creality sent a second motherboard, which I swapped out. Tried flashing firmware again, but same result. No response on the screen when flashing the marlin firmware, and unable to connect the sonic pad when flashing the klipper firmware.:

After two new motherboards for this thing, I’m thinking I’m doing something wrong in flashing the firmware? Formatting the SD card as instructed each time to remove any old bin files. Copying the .bin file, or exporting whatever the sonic pad does, and then placing the card in the printer. Turn on the printer, without anything else plugged into the USB slot. Screen stays blank, always. When flashing klipper, i then connect the sonic pad, but it can’t establish a connection. Turn everything off, and go through these motions again, and again. Nothing changes. Any idea what I’m doing wrong? Thanks!