Problems printing with PETG

  • 3D Printer Model: Ender 3 Pro
  • Slicer: Cura Ver 5.7.0
  • Hardware Setup:Standard with direct drive and dual z axis screw
  • Problem description: Awful Prints
  • What I tried: Changing temp, speed, etc

I have been printing now for around 3 years or so. Nearly everything I print has been with PLA or PLA+. Since getting over the usual teething troubles when you first start printing, everything has been perfect for 2 years plus, without any problems. UNTIL PETG WALKED INTO MY LIFE.

I have tried using PETG maybe half a dozen times, with no success. I keep reading that PETG is as easy to print with as PLA. Not in my case lol. Each time I try, I end up giving up after trying various scenarios.

I have just tried again with terrible results, again. See pic.

OUCH! I did leave this alone for 10 minutes as I had a visitor arrive. Came back to this. The same as I’ve always had.

It was a brand new reel of PETG, opened specially for this print. I set all settings as recommended on the packaging. Tried slowing It down, adjusting both bed and hot end temps. Then after about ! hour or so of trying, gave up again as I was getting nothing else done. It was only supposed to be a 20 minute print but after around 2 hours of total frustration, I surrended, again.

Its got to be me doing something siily as its all supposed to be very easy with PETG.

PLEASE. Is there anyone out there who can shed some light on the scene, before I end up in the loony bin. HELP!!!

This seems like a hotend clog.
Did you confirm there’s nothing clogging it?

I agree.

It may be a clogged nozzle / heatbreak.

Dissasemble and check it !