Sidewinder X1 SKR 1.3 y Axis skipping losing steps

  • 3D Printer Model: sidewinder X1 SKR 1.3 mod with BL touch
  • Slicer: cura 5.3
  • Hardware Setup: SKR 1.3 TMC2209, BL Touch , Sock Screen and stepped Stock
  • Problem description: printer is losing steps or randomly printing and dimension alone y Axis. Some times half the print is of then a staggered shift in y Axis.
  • What I tried: swapped motors and stepper drivers. Formatted SD card and usb re sliced voron test cube. I’ve tried to reinstall firmware but nothing happens as I get the .cue for as normal. Is there a way to fresh install firmware on skr1.3. I’ve checked all stepper drivers have the correct vref. Is this controlled by firmware? As the y Axis motor seems to be cold or just a little warm! Normally they tend to be very warm to touch!

As you can see from image the bottom of cube for first 3-4 layers is ok then all of a sudden y Axis goes haywire and that happens. As the print is processing the y Axis start to knock as of I’d it’s losing steps. This happens at different time of the print. It’s not always at a specified time etc.

Your problem might be related to the VREF of your Y axis, if you are saying that the motor is not warm.
Increasing that might help