Sidewinder x2 klipper make Flash error

  • 3D Printer Model: Sidewinder x2
  • Slicer: N/A
  • Hardware Setup: Ruby 1.2 mainboard (same as one i had that did work with this), raspberry pi model 3B
  • Problem description: I am going through the process of replacing my mainboard because the old one broke a mosfet. I am now installing klipper I have the printer in DFU mode, and the PI can see it as such, but when I try to run the ‘make flash FLASH_DEVICE=0483:df11’ command I receive error 255. I have the correct flash device, it is from lsusb, but I still get the error.
    I put it in DFU mode via the pin. When I tried to do it the other way, device manager didnt detect anything in the other COM ports.

Here is the entire error:

pi@fluiddpi:~/klipper $ make flash FLASH_DEVICE=0483:df11
** Flashing out/klipper.bin to 0483:df11**
sudo dfu-util -d ,0483:df11 -R -a 0 -s 0x8000000:leave -D out/klipper.bin

dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
dfu-util: No DFU capable USB device available

Failed to flash to 0483:df11: Error running dfu-util

If the device is already in bootloader mode it can be flashed with the
following command:
** make flash FLASH_DEVICE=0483:df11**
** OR**
** make flash FLASH_DEVICE=1209:beba**

If attempting to flash via 3.3V serial, then use:
** make serialflash FLASH_DEVICE=0483:df11**

make: *** [src/stm32/Makefile:82: flash] Error 255

  • What I tried:
    I tried running the other commands it listed in the error code, with no change. I tried messing with the menuconfig to see if anything there could help, with no result. Ive checked and rechecked the commands and wires and it all seems like it should be in place.

When I replugged in the screen I noticed that it is just repeatedly booting, then shutting down a half second later

Did you put the board in DFU mode using the jumper pin?

Yes, I already had the board open since I was swapping it out so I used when I ran lsusb it confirmed that it was a device that was in DFU mode

Maybe the bootloader is broken? Not really sure.
I would try to “unbrick” the board with the stock firmware first.

How would I go about replacing the boot loader? I might have the right cables but I’m not sure how I do that on this board.

Check the manual from Artillery, where they show how to flash the board.

Located the issue, it was unrelated to firmware.

I was in a bootloop, caused by some sort of short in the wires. I unplugged everything from the mainboard except the power supply, and was able to keep plugging things in and turning it on until i figured out which connection was causing the bootloop. from there I narrowed it down to one of the wires that lead to the ribbon cable. I then moved up to the printerhead board and disconnected everything there to check it, and was able to find that when the probe was connected it would start bootlooping. I replaced the probe with a BLTouch that i had on hand after soldering together and it worked fine.

TL:DR: somehow my probe had put my mainboard in a bootloop that caused it to restart while i was trying to reflash it. replaced my probe and i could proceed just fine.